"Sharing Violation" dismissed issues are erroneously reopened
Incident Report for Clayton
Resolved
This incident has been resolved.
Posted Jan 19, 2024 - 20:07 GMT
Monitoring
The engineering team is monitoring the progress on recovering scans.
Posted Jan 19, 2024 - 17:05 GMT
Identified
Our team has successfully identified the root cause of the problem. Contrary to our initial understanding, the issue did not involve the reopening of dismissed issues. Instead, it was traced back to a failure in the logic responsible for identifying test classes, leading to the erroneous detection of issues within these classes.

Our engineering team has addressed this underlying problem, and the necessary fixes have been implemented. The service is now restored to its intended functionality, we will now begin the recovery process for scans that were affected by this problem.
Posted Jan 19, 2024 - 14:11 GMT
Investigating
Following the recent release of our service, we have identified a regression that has led to the detection of certain issues previously dismissed. At present, these issues appear to be associated with the "Sharing Violation" rule. Our team is actively investigating the root cause of this problem.
Posted Jan 19, 2024 - 12:26 GMT
This incident affected: Clayton (Code Review Workers).