Email delivery delay
Incident Report for Clayton
Resolved
This incident has been resolved.
Posted Sep 10, 2018 - 22:36 BST
Identified
We are currently experiencing a delay in email delivery due to an issue affecting our email delivery provider.
Posted Sep 10, 2018 - 16:17 BST
This incident affected: Web.